Hi all
I try to change the FX for Deck 2 using the FX SELECT button. However, the button does not change FXs on Deck 2, just on Deck 1. Sliding the switch (1, 2, 1&2) to different positions does not fix the problem.

I can change the FX from the Rekordbox using the mouse but not from the controller.

Example: I play a track on Deck 1 using ECHO, click FX SELECT, and change it to FLANGER. I transition to a track on Deck 2, switch BEAT FX to "2," and then when I try to select a new filter for Deck 2 using the FX SELECT, it still changes Deck 1 but not Deck 2.

Has anyone encountered the same problem, and how did you fix it? Am I missing a setting in Rekordbox?