Results 1 to 5 of 5

Thread: KRK Rokit speakers only playing from one whilst connected to decks

  1. #1
    New Member
    Join Date
    Apr 2020
    Location
    London
    Posts
    2

    KRK Rokit speakers only playing from one whilst connected to decks

    Hello all
    Was wondering if anyone has a solution to the following or can point me in the direction I might get an answer. Basically my KRK rokit speakers work fine when I play music from my laptop, using an aux from the laptop to a rca converter with two male extensions that plug directly into the speakers. However when I use two rca male-male cables to connect my decks directly to the speakers, only one speaker works (the same one every time, no matter what wire configuration I use). This makes me think that one speaker is broken, however how can it work when connected to a laptop and not with my decks?

    Any help is appreciated!

  2. #2
    Member
    Join Date
    Jan 2014
    Location
    Ottawa Ontario, Canada
    Posts
    1,873
    Can you post some pictures of the equipment and cables in question. Sounds like there are some different cabling pieces involved with each setup so there is a possibility of a bad cable but it could also be a configuration problem.
    Paul O'Brien
    Old Tech Guy
    www.Techott.com

  3. #3
    Moderator pete's Avatar
    Join Date
    Feb 2012
    Location
    old orléans
    Posts
    2,142
    connect my decks directly to the speakers,
    I really hope you are not connecting phono turntables directly to speakers.
    They need a pre-amp before they will give e line-level signal.

    If you are talking about CD players, then change the cable you are using (usually cables are the first to fail in a signal path).
    bored, curious, deaf or just bad taste in music?
    finally a mix by me
    and what's this, another shoddy mix...another dull mix

  4. #4
    New Member
    Join Date
    Apr 2020
    Location
    London
    Posts
    2
    379A4DAD-1F26-4285-B378-3F53079AF051.jpgA49E243B-F7AC-4EFB-AD84-8FB1AEA0BB34.jpg

    Thanks for the response.

    The two photos attached are...
    1- The speakers connected directly to my mac (with RCA input in the back of the speakers) - both work here
    2- The speakers connected to my decks. RCA to aux adapter coming from the decks and then the same cable used before to connect the adapter to the speakers

    I have also got two rca cables on their own which I can use to connect the decks to the speakers with no adapter, but I get the same issue.

    Thanks!

  5. #5
    Member
    Join Date
    Jan 2014
    Location
    Ottawa Ontario, Canada
    Posts
    1,873
    OK in that case it sounds like the controller is only producing output at one of the RCA jacks, that could be a hardware problem that will require a visit to an electronics tech but it could also be a software configuration problem. Have a look through the software settings to see if it is setup for stereo or mono output. Try switching it back and forth just to see if resolves itself, software can be glitchy sometimes.

    What controller is that? Does it have any other outputs besides RCA?
    Paul O'Brien
    Old Tech Guy
    www.Techott.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
a