Page 2 of 12 FirstFirst 1234 ... LastLast
Results 11 to 20 of 119

Thread: DIY rotary DJ mixer

  1. #11


    Here's a pic of the project as of now... the mains and all the input modules are in place as well as the first two of the input channels (mic & phono1)

    EDIT : It's a really tedious job wiring all the potentiometers...

    Quote Originally Posted by steveryan View Post
    What's your thoughts on having two isolators where you can assign either one to any channel?

    If you're using two turntables, you can have an isolator for each one instead of just one for both.
    I guess it'd be "easier" to put per channel EQs instead if that was the case... put any sort of assigning matrix in a mixer and you can broadly twice the amount of cabling unless you know how to make PCBs... and I'm too lazy for that sort of engineering as this is my first project. (edit : I don't mean to sound rude here but one could use a multiplexer or something, however those require an extra bit of technical know-how)

    P.S I just ran out of cable and I thought 10m would be enough... little did I know.

  2. #12

  3. #13
    Here's some more wiring..



    There's the rest of the channels done and the summing stage in place.

  4. #14
    Lots of hum... I tried the mixer without the Lundahls in the output. (edit : I tried one of the RIAA preamps too but they didn't seem to let any sound through)

    I noticed the hum stops when you turn the master all the way up, which is weird. Turning the pots doesn't seem to make a difference in the perceived signal level.

  5. #15
    Here's the most recent build pic..



    I've added a separate unbalanced (edit : RCA) booth out since though... it's missing the monitoring section as of now.

  6. #16
    I tested wiring the trim straight to the preamp PCB although it's a 100k stereo log (the trimmers used were 1kOhm) and it works to some extent. As for the build it's not fully functional with a PSU/monitoring missing and the left master channel is dead.

    So far I've burnt two 10A fuses and also broke a multimeter so it might take a while to finish it.

    EDIT : both line channels are functional now although a bit distorted.. it could be due to the power supply used.

  7. #17
    The headphone amp seems to be working despite the desoldering incident wherein I damaged the PCB... I also got the cue selector switch in place.

  8. #18


    Here's the most recent build with monitoring and a cue selector switch... it's still missing a PSU though.

  9. #19


    Here's a front shot... it's like 95% functional (edit : in terms of mixer functionality) now with 2 line channels; the RIAA's aren't working (I think I need a pair of preamplifiers for them) and it's still missing the PSU plus there's something wrong with the master channel. The monitoring seems to work to some extent and the EQ is still underway.

  10. #20
    Looks nice. Why do you think you need a pair of preamplifiers? How many channels does each phono preamp board have?
    And, how exactly are you connecting the potentiometers? I've built mixers and lots of other audio circuits, I can help...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
a