Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: JBL 515 volume issuw

  1. #1

    JBL 515 volume issue

    Has any one have an issue like me?
    I'm running 2 prx 515 as my PA system for my DJ service. So what's happening is that one of the speakers would play at a normal volume and all if the sudden it drops its volume. There is sound coming out but at about 90% less volume.
    I'm always very careful to away from the red on my mixer (djm 350), I typically don't give pass the first orange light. The speaker volume on the back is set at about 1 or 2 o'clock.
    So I know I'm not clipping and distorting anything.
    I've tried multiple cables, different mixers, different power cables.

    Anyone with a similar problem?

    Any help would be greatly appreciated.
    Thank You
    Sent from my DROID RAZR using Tapatalk 2
    Last edited by MikeLtheDJ; 04-14-2012 at 08:54 PM.

  2. #2
    Member windspeed36's Avatar
    Join Date
    Feb 2012
    Location
    Melbourne, Australia
    Posts
    1,019
    Is it dropping when you increase the volume past a certain point? I'd take it in to JBL
    Quote Originally Posted by Dick Rees
    Don't worry about it. Set them up, turn them on, listen to them, adjust if needed. No matter what you do, they're still going to sound like Eons

  3. #3
    Member bumpyjonas's Avatar
    Join Date
    Feb 2012
    Location
    Brooklyn, NY
    Posts
    1,122
    I own several JBL powered speakers, never had that issue, as windsppeed36 indicated take to JBL and let them troubleshoot the issue.
    " Mr. Nichols Just A Guy Who Plays Music"

    Listen To Good Tunes..Play Good Tunes..Spin The Tunes They Wanna Hear

  4. #4
    Ok, thank you ill get it done. The only thing I hate is that the closest repair shop that will take a look at it is almost 2 hours away.

    Sent from my DROID RAZR using Tapatalk 2

  5. #5
    Member
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    478
    Have you tried changing the speakers side for side? Does this problem exist only with one speaker, or does it change when you swap left for right?
    Looks like you checked the silly things, like cables. Have you gone all the way thru the signal chain, including source into the mixer?
    In other words, are you sure it's a problem with a speaker, and not a problem somewhere else?
    I would hate to see you waste two hours or more, only to find out the problem isn't with your speaker, but somewhere else in the signal chain.
    Don't mean to ask stupid questions. Just thought I'd throw it out there...
    Last edited by Evil Steve; 04-15-2012 at 11:42 AM.

  6. #6
    Quote Originally Posted by Evil Steve View Post
    Have you tried changing the speakers side for side? Does this problem exist only with one speaker, or does it change when you swap left for right?
    Looks like you checked the silly things, like cables. Have you gone all the way thru the signal chain, including source into the mixer?
    In other words, are you sure it's a problem with a speaker, and not a problem somewhere else?
    I would hate to see you waste two hours or more, only to find out the problem isn't with your speaker, but somewhere else in the signal chain.
    Don't mean to ask stupid questions. Just thought I'd throw it out there...
    Yes I've check that. I also tried a different source. I use a Numark hdmix as a backup.
    I'm guessing its not a common problem.

    Thank you all for the reply

    Sent from my DROID RAZR using Tapatalk 2

  7. #7
    Member
    Join Date
    Feb 2012
    Location
    Alberta, Canada
    Posts
    279
    It sounds like it may be thermaling out on you (overheating). The JBL prx 515's are famous for that, bad heatsink design. I own 2 of them and the solution that the JBL dealer provided for me is shown in the following picture.


    The solution is a 4" computer fan mounted on the wall blowing air onto the heatsink. Works perfectly now. Getto but there is nothing else that works. I'm willing to bet you have the same problem.

    JBL knows about this problem but refuses to admit to it less their reputation gets damaged. That is why they quickly discontinued that line and replaced it with the 615's series. It is a design flaw that they won't own up to.
    Last edited by Coronaoperator; 04-15-2012 at 08:29 PM.

  8. #8
    Wow that's great ....

    Sent from my DROID RAZR using Tapatalk 2

  9. #9
    So after beeping at the repair shop for over a week, they can not reproduce the issue. My warranty runs out in September. Any suggestions?

    Sent from my DROID RAZR using Tapatalk 2

  10. #10
    I need to mention that this only happens after a long time being on. I wonder if there is such a thing as a duty cycle on them.

    Sent from my DROID RAZR using Tapatalk 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
a