Results 1 to 6 of 6

Thread: Audio Technica LP120 Help

  1. #1
    New Member
    Join Date
    Sep 2017
    Location
    UK
    Posts
    3

    Talking Audio Technica LP120 Help

    Hi,

    I'm a complete novice and I am looking for some help in regards to setting up equipment.

    I bought a cheap controller over a year ago to practice with and mess around which I really enjoyed which as made me go on and buy some turntables and I have just purchased a pair of LP120s

    I was given a Numark M101 mixer by a friend and the speakers I have are M Audio AV42. The issue is that I can connect 1 Turntable to the speaker and produce sound but If I connect both to the mixer I can faintly make out some sound with the volume cracked to the max.

    I'm obviously missing out something and/or doing something stupid but just looking for some help.

    are these speakers and mixer compatible with the turntables? Do I need an amp ?

    Advice would be greatly appreciated.

    Thanks.

  2. #2
    Check the mixer's input. The turntables should be inserted in the phono input. Some inputs have a line/phono selector at the back. Select "phono".
    Works1200 - the Technics 1200/1210 specialist - FB page
    Nicadraus' mixcloud page

  3. #3
    New Member
    Join Date
    Sep 2017
    Location
    UK
    Posts
    3
    Yeah I had messed about with that.

    The turntable was set to phono. As was the mixer but I couldn't hear a think. When I changed it to line I could faintly hear music coming out the speaker . But I mean very faint and that was with the volume at max.

  4. #4
    Supermod pea Manu's Avatar
    Join Date
    Feb 2012
    Location
    On your screen
    Posts
    5,722
    Moved to beginners

  5. #5
    New Member
    Join Date
    Aug 2013
    Location
    Ogden, UT. USA
    Posts
    2
    On the Audio Technica LP120, set the pre-amp switch on the back to phono. On the Numark M101, plug turntables into the phono inputs and set the input switches to phono. Set the channel gain knobs to about mid range. then turn up the volume sliders all the way up. Turn up the master volume knob. If that does not work, try the same procedure setting everything to Line. Including the the pre-amp switch on back of the turntables. Set the crossfader to the center.

  6. #6
    New Member
    Join Date
    Sep 2017
    Location
    UK
    Posts
    3
    I’m a bit late in replying but this worked. Thank you !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
a