Results 1 to 4 of 4

Thread: Is my mixer broken?

  1. #1
    New Member
    Join Date
    Jul 2012
    Location
    London
    Posts
    3

    Is my mixer broken?

    I've got an Urei 1610 mixer. Just took it on a 4 hour drive in a hot car which although wasn't ideal, had to be done. I've just plugged it in and it's making a bassy popping sort of noise through my speakers, is it completely broken or is there a stupid solution that I'm stupidly missing?

  2. #2
    New Member
    Join Date
    Apr 2012
    Location
    Willmar MN
    Posts
    38
    Did you perhaps take it directly from this really hot car straight into a well-chilled air conditioned house or venue of some sort?? I'm not syaing it is the cause, but it could be a suspect. Going from one temp extreme to the opposite can pose some problems for any electronics that have an enclosed casing and turned on right away. The drastic temp change can sometimes cause condensation/moisture inside the housing of the mixer because the inside is not able to cool down at the same temp as the outside of the casing. And as you could imagine, if this happens, and moisture gets on any circuitry of any sort, could cause some problems. Other than that, I'd just be doing the standard trouble shooting, check all cables for lose connections, frayed or pinched cables, etc. Best of luck! Hope it isn't anything too serious!

  3. #3
    Are you using turntables? Sounds like a ground wire issue.

  4. #4
    Junior Member
    Join Date
    Jun 2012
    Location
    Pennsylvania
    Posts
    95
    So what happened? Did the problem solve itself? Any further info?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
a