PDA

View Full Version : MixTrack URGENT HELP NEEDED!



steppinrazor89
04-06-2012, 11:46 PM
hello there,

has anyone ever had problems with their mixtrack hooking up to traktor 2? it works fine on my PC but not my macbook Pro, i've installed the program and that works fine but when i import the mixtrack.tsi file the right deck is constantly playing and the play button wont turn off

i've had a look for drivers the mixtrack page on the numark site says that it is 'class-compliant USB device' and doesn't need a driver.

im running OSX 10.7.3, quad-core i7, 4GB RAM, Edirol FA66 sound card.

i'm running a full version of Traktor 2.0.3, i've tried changing the mapping on the standard .tsi that comes with the software, i've also tried getting another .tsi file (from traktorbible.com) and tried fiddling with that.

the same thing seems to happen, the faders and rotaries work with no problems, but ALL of the buttons are sketchy: most of them don't work at all, the ones that actually light up stay lit even after un-toggling them rendering them useless... this happens even after i've redone the mapping so that it is absolutely correct in corresponding with the mixtrack's buttons.

the thing that is confusing me the most is the fact that it works absolutely fine on my PC with no hassle...

the only thing i can think of (it might be because in vaguely noobish) is to back track from lion to snow leopard, because a mate of mine has traktor 2.0.3 with a mixtrack (a slightly newer mixtrack i think) with no problems on snow leopard... but this seems like a bit of an effort, so i'm hoping theres a solution, because i dont even know if that will work lol

i am playing a gig a week on tuesday so any help is desperately needed and would be greatly appreciated!

what do you think?

lucas


http://www.youtube.com/watch?v=RMJ6pN_SFT4&feature=youtu.be

steppinrazor89
04-07-2012, 05:38 PM
ok i've updated a little bit by now, this is where i'm at:


http://youtu.be/pcBmCug_DgA

ok so i've gone through the mapping and tried to set it up to work as the mixtrack should out of the box (standard .tsi file) and i've managed to set the jog wheel up to work with the scratch button off, and scratching to work with the scratch button on, but when i stop scratching traktor doesn't carry on playing the track... im not sure if im mapping it incorrectly or using the wrong functions (im very new to making my own mapping).

Andrew B
04-07-2012, 05:49 PM
First update to the latest Traktor version through Service Center. 2.1.2 I think?

edit: 2.1.3 is the latest

steppinrazor89
04-07-2012, 10:09 PM
will this actually help? i've tried it on Traktor LE, Traktor 2 LE, and Traktor PRO 2 and it doesn't want to work properly on any of them :/