PDA

View Full Version : Problem with mixer channels



snowmonkey
02-06-2012, 09:11 AM
Hi all,

I hope someone can help me to troubleshoot this. I have a Kam Kap 1500 mixer - I know not the best mixer in the world but don't bash me for that :lol:

I am in the middle of a two week festival and it has started playing up. I have always used channel 2 and 3 assigned to the crossfader. However, when the crossfader was hard right (channel 3) you could still hear channel 2, sometimes at full volume. So I assumed the crossfader had gone and replaced it. I then got the same problem.

I have tried using contact lube on it, and still the same problem.

I then tried using channel 1 instead, and tentatively, that seems to work OK. Could this mean a whole channel is dead/on the way out? Are these sorts of things usually serviceable?

I don't really understand how mixers are wired up so I am unsure how to trouble shoot this problem. Any help gratefully received.

Also, it I mix using only the main faders, could they eventually wear out (they are not replaceable like the cross fader).

Oh yes, it is 2 1/2 years old and has had a fair bit of use....

Thanks,

Ed

Subprime
02-06-2012, 09:42 AM
Well usually I would suggest replacing the crossfader...... but.......

Line faders will of course wear out, but seem like your only option at the moment. They tend to get whacked around a bit less than the crossfader as well, so that might buy you some time. Might be time to start saving for a decent mixer ay?